Functions

 Problem


Functions are a bunch of statements glued together. A function is provided with zero or more arguments, and it executes the statements on it. Based on the return type, it either returns nothing (void) or something.

The syntax for a function is

return_type function_name(arg_type_1 arg_1, arg_type_2 arg_2, ...) {
    ...
    ...
    ...
    [if return_type is non void]
        return something of type `return_type`;
}

For example, a function to return the sum of four parameters can be written as

int sum_of_four(int a, int b, int c, int d) {
    int sum = 0;
    sum += a;
    sum += b;
    sum += c;
    sum += d;
    return sum;
}

Write a function int max_of_four(int a, int b, int c, int d) which returns the maximum of the four arguments it receives.

+= : Add and assignment operator. It adds the right operand to the left operand and assigns the result to the left operand.
a += b is equivalent to a = a + b;

Input Format

Input will contain four integers -  , one per line.

Output Format

Return the greatest of the four integers.
PS: I/O will be automatically handled.

Sample Input

3
4
6
5

Sample Output

6


Here's my Code in C++

#include <iostream>

using namespace std;

int gede(int a, int b, int c, int d);

int main(){
    
    int a, b, c, d;
    
    cin >> a >> b >> c >> d;
    cout << gede(a, b, c, d);
}

int gede(int a, int b, int c, int d) {
    int hasil = a;
    
    if (b > hasil) hasil = b;
    if (c > hasil) hasil = c;
    if (d > hasil) hasil = d;
    
    return hasil;
}


No comments

Powered by Blogger.